Documentation/3.4

From SlicerWiki

(Redirected from Documentation-3.4)
Jump to: navigation, search
Home < Documentation < 3.4

For the latest Slicer documentation, visit the 4.3 page.

Nightly 4.3 4.2 4.1 4.0 3.6 3.5 3.4 3.2 ALL VERSIONS

Contents

Introduction

This page is a portal for documentation about Slicer 3.4. For information for software developers, please go to the Developers page (see link in navigation box to the left).

How-To Tutorials

Feature Request and Problem Reports

We have an issues tracker for Slicer 3. You need to create an account for filing reports. We keep track of both feature requests and bug reports. Make sure to use the pull-down in the upper right to select Slicer 3.

System Requirements

  • Hardware: The hardware requirements are driven by the kind of analysis you wish to perform. For large data sets we suggest the 64 bit linux build on a machine with several gig of memory (e.g. a 1000 slice CT is half a gig of memory just to load plus there are temporary copies in memory during any processing steps). Note that Windows often does not make the full system memory available to applications.
  • Disk Space: In addition to the installation directory (about 200 meg depending on platform), operations like installing downloaded extensions, caching internet data downloads, and running external programs will require additional memory; the exact amount depends on the operations you perform. To be safe, an extra gig or more of free disk space is a good idea for "typical" uses such as neuro MR analysis.
  • Directory Settings: There are several user-selectable directory paths. Please confirm that these paths point to locations with sufficient storage space for your intended use.
    • View->Application Settings->Module Settings->Temporary Directory is used as scratch space when running modules. By default this points to a new temp directory in your home directory.
    • View->Application Settings->Module Settings->Extensions Install Path is where newly downloaded extension modules will be saved.
    • View->Application Settings->Remote Data Handling Settings->Cache Directory is where downloaded data is stored for possible re-use. This defaults to the same as the Temporary Directory.

List of Modules

Overview

  • The documentation on this page has been created for Slicer 3.4 and discusses the features and capabilities of menu items and panels. It is intended to be used as a live reference manual. This is a wiki. You are welcome to add to the content and improve it.
  • In addition to the hundereds of smaller changes and improvements to Slicer in general, there are two substantial new addtions to Slicer 3.4:
    • A new infrastructure to find and add plug-ins from a repository. See here for more information.
    • A new database using XNAT desktop. See here for more information.

Main GUI

Modules

  • Please copy the template linked below, paste it into your page and customize it with your module's information.

Slicer3:Module_Documentation-3.4_Template

  • See above for info to be put into the Help and Acknowledgment Tabs
  • To put your lab's logo into a module, see here for plugin module, and here for loadable module.

Core

Additional modules may appear in this section of the menu if they are not otherwise categorized by the developer.

Specialized Modules

Please adhere to the naming scheme for the module documentation:

  • [ [Modules:MyModuleNameNoSpaces-Documentation-3.4|My Module Name With Spaces] ] (First Last Name)

Wizards

Informatics Modules

Registration

Segmentation

Statistics

Diffusion

DWI

DTI

Tractography

IGT

Filtering

Surface Models

  • Modelmaker (Nicole Aucoin)
  • Grayscale Model Maker (Bill Lorensen)

Batch processing

Converters

Work in Progress

Various tools in development will appear here depending on the version of slicer you are using.

Developer Tools

Extensions for Downloading

Slicer on NITRC

Work is in progress to create infrastructure for searching and loading extensions. See Slicer3:Extensions for more information.

  • This will allow contributors and software developers to post their own Slicer extensions and have them compiled against the "official" versions of Slicer.
  • Users can browse these contributed extensions and install them on their own versions of Slicer.


We are currently using NITRC as a repository for contributed extensions. As a general rule, we do not test them ourselves, it is the downloaders job to ensure that they do what they want them to do. Click here to see a listing of Slicer 3 extensions on NITRC.

Extension manager dialog box

To add extension modules to an installed binary of slicer:

  • Use the View->Extension Manager menu option
  • The dialog will be initialized with the URL to the extensions that have been compiled to match your binary of slicer.
    • Note installing extensions from a different repository URL is likely to be unstable due to platform and software version differences.
    • You can select a local install directory for your downloaded extensions (be sure to choose a directory with enough free space).
  • Select the extensions you wish to install and click to download them. Installed extensions will be available when you restart slicer.
  • To turn modules on or off, you can use the Module Settings page of the View->Application Settings dialog.

XNAT Desktop and FetchMI

  • Work is underway to use XNAT desktop (xnd) as a local database for Slicer. This database will exist in parallel with the other load and save mechanisms and will allow to download/upload individual files or entire scenes with all their dependent files.
  • Users of Slicer will have to install xnd on their computer. Once set up, the FetchMI interface will allow users to upload and download mrml scenes with all the dependent files, or individual volumes, models, other components of slicer scenes.
  • See here for a link to the download site for xnd. See here for documentation on how to install XNAT desktop on your computer.
  • On Macs and Linux you currently have to change permissions of the executable after installation.
  • In the future (summer 2009) xnd will be able to upload and download mrml scenes to xnat enterprise.
  • FetchMI is the current interface inside slicer for exploring information stored in xnd and down and upload such data. It is a "sandbox" implementation to help us understand how users will want to use remotely stored data and metadata in the Slicer environment. Eventually, FetchMI's remote load and save will be integrated with Slicer's existing load and save interfaces, and FetchMI's data tagging functionality will be more fully developed as a new metadata authoring module.
  • See here for more information about FETCHMI. User comments and suggestions are welcome.

FreeSufer Integration

  • FreeSurfer surfaces and scalar overlays can be loaded via the Models module and MGZ volumes can be loaded via the File -> Add Data widget.
  • More detailed information can be found here.

Requirements for modules to be added to the release

  • The module is feature complete for the tasks advertised
  • The module has a test. See here for more information.
  • Module has documentation on the Slicer wiki. Please use the template provided here to structure your page.
  • Please add a pointer to the documentation on the Slicer wiki to the the Help tab of the module. See the Editor module in Slicer for an example.
  • The contributor (and their manager/advisor), the lab (with labs/institution logo) and the funding source (with grant number, logo optional) are listed in the Acknowledgment tab of the module. Please see the Models module for and example. The people listed in the acknowledgement will be the primary people for support and maintenance relative of the module.
    • Style Guide: All acknowledgment icons should be 100x100 pixels, preferably in png format.
    • Accessing logos: Icons for BIRN, NAC, NA-MIC and IGT are included in Slicer3/Base/GUI//vtkSlicerBaseAcknowledgementLogoIcons.cxx/h and resources for them are in Slicer3/Base/GUI/Resources/vtkSlicerBaseAcknowledgementLogos_ImageData.h. The API for vtkSlicerModuleGUI provides access to these icons.
    • Adding logos: Please add your logos and additional image resources to the location reference above in order to promote shared use (and to prevent duplication in the code.)
Examples for the Help and

Acknowledgment Panels

Personal tools